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Painting is $20 US shareware. Use the enclosed Register program to register. For more details, see
the section on “Registering Painting.” Painting requires at least a 68020 Mac or a Power Mac, and
System 7.5 or greater.

If you don’t like manuals
Painting isn’t hard to use so you can dive in and try it out. I strongly recommend that
you look over the section on Shortcuts and the section on Features though.

What is Painting?
Painting is a simple yet powerful graphics program and it is written by Sarwat Khan. It’s
extremely useful for creating and editing graphics such as snapshots, icons, but it can be
used to make fabulous artwork as well.

Features
• Complete set of paint tools, including a paint brush, shape tools, and flood fill.
• Multiple selection types, including lasso, ellipse, and free form.
• A powerful text tool which supports smoothing (anti-aliased text).
• Supports pressure-sensitive graphics tablets.
• Lets you apply QuickTime 3 Filter Effects
• You can scale, rotate, and flip images.
• Simple brightness adjustment.
• Separate fill and stroke for shapes.
• Can create documents using Black and White, 256, thousands, or millions of colours.
• A “Paste New” command to create new documents off of the clipboard.
• A “Print One Copy” command for easy printing.
• Paint brush can be up to 50 pixels wide.
• You can configure hot keys to select tools from the Tool palette.
• Customised colour sets. They let you organise colours into groups. You can also give

your colours names.
• Information palette that, among other things, indicates the dimensions of the current

selection.
• You can drag and drop colours from the colour palette into your document for flood

filling.
• Full stationery support.
• With QuickTime 2.5 or better installed, Painting can directly open JPEG, GIF, TIFF,

Photoshop and other files, and save JPEGs.
• With QuickTime 3.0 installed, Painting can save JPEG, BMP, Photoshop, and

QuickTime files. QuickTime 4.0 lets you save PNG files and set a maximum file size
when saving JPEGs.

• Supports the Mac OS 8 Appearance Manager.

Registering Painting
Painting is shareware. That means if you like it and decide to keep it, you must pay for it.
You have 30 days to try out Painting.

Painting has the following pricing:
1 single user license is $20.
2–15 single user licenses are $15 US per user.
16–30 single user licenses are $12 US per user.
30+ single user licenses are $9 US per user.

A Site License costs $450 (equal to 50 users) and covers all locations for your organisation
within a 160 kilometre radius of your site (100 miles). One big advantage of a Site License
is that you do not need to keep track of how many people at your site are using the
software.

Paying for Painting is fairly simple. Open the Register program that comes with Painting.
Enter your name, your email address, and the number of single user licenses you want to
purchase (or Site licenses). Save or Copy or Print the data from the Register program and
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send the data and payment to Kagi. More specifics on the Register program to follow.
Kagi handles my payment processing.

If you do not have an email address, please make sure the “Postcard Receipt” button
in Register is checked. It will cost you a US dollar, but it will pay for the cost of sending
the registration code to you. Otherwise Kagi will charge me for it.

You can also pay for Painting online at Kagi’s Online Ordering site. Point your browser
to http://order.kagi.com/?F5 and fill in the information.

If paying with Credit Card or First Virtual, you can email or fax the data to Kagi. Their
email address is sales@kagi.com and their fax number is +1 510 652-6589. You can either
Copy the data from Register and paste into the body of an email message or you can Save
the data to a file and you can attach that file to an email message. There is no need to
compress the data file, it's already pretty small. If you have a fax modem, just Print the
data to the Kagi fax number.

Payments sent via email are processed within 3 to 4 days. You will receive an email
acknowledgement when it is processed along with a registration key that will remove the
annoying splash screen at startup. Payments sent via fax take up to 10 days and if you
provide a correct Internet email address you will receive an email acknowledgement.

If you are paying with Cash or USD Cheque you should print the data using the Register
application and send it to the address shown on the form, which is:

Kagi
1442-A Walnut Street #392-F5
Berkeley, California
94709-1405 USA

You can pay with a wide variety of cash from different countries but at present if you pay
via cheque, it must be a cheque drawn in US Dollars. Kagi cannot accept cheques in other
currencies, the conversion rate for non-USD cheques is around USD 15 per cheque and
that is just not practical.

If you have a purchasing department, you can enter all the data into the Register
program and then select Invoice as your payment method. Print three copies of the form
and send it to your accounts payable people. You might want to highlight the line that
mentions that they must include a copy of the form with their payment.

Kagi can not invoice your company, so you need to act on my behalf and generate the
invoice and handle all the paperwork on your end. Please do not fax or email payment
forms that indicate Cash, Cheque or Invoice as the payment method. As far as we know,
there is still no technology to transfer physical objects via fax or email and without the
payment, the form cannot be processed.

Payments sent via postal mail take time to reach Kagi and then up to 10 days for
processing. Again, if you include a correct email address, you will hear from Kagi when
the form is processed.

Painting has a protection scheme and when you pay, we tell you your registration code
that you use to disable the protection scheme (the annoying dialog at startup). If you do
not have an email address, please enter your complete postal address and please
remember, we do not know what country you live in so please enter that into the postal
address also.

If you do not have an email address you should selecting the Postcard Receipt so that
Kagi can inform you of your registration code. Kagi transmits the registration codes via
email and paid postcard receipt only.

Using Painting’s Tools
This section describes how to use each of the tools in the tool palette, and any special
features they may have. Be sure to read the Tips & Shortcuts section on Modifiers, which
lets you use the tools below in different ways.

Note  You may want to read the section on “Colours” to find out the
difference between a fill colour and a stroke colour.
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Rectangle Selection  Selects a rectangular area of your document. Double clicking the
tool in the tool window will select your whole document.

Lasso Selection This tool is available from the popup menu in the upper right hand
corner on the Tools palette. The lasso tool is used to select an area of your document
while excluding surrounding space. If you don’t get it, try it out (paint something with
the paint brush, and then use the lasso tool around it). Double clicking the tool in the
document will make a flood fill selection like a magic wand tool (if you don’t get it, try it
out).

Rectangle Lasso Selection  This tool is available from the popup menu in the upper right
hand corner on the Tools palette.  It works just like the lasso tool, but instead of drawing
all the way around the graphic that you want to lasso, you can just draw a rectangle
around it.

Freehand Selection  This tool is available from the popup menu in the upper right hand
corner on the Tools palette. Just draw with it as you’d draw with the pencil tool. When
you let go of the mouse button, Painting will connect the points where you started
drawing from and where you let go of the mouse button.

Ellipse Selection  This tool is available from the popup menu in the upper right hand
corner on the Tools palette. It lets you make a selection that is shaped like a circle.

Hand  The Hand tool (also called the Grab tool) is used to scroll your document without
using the scroll bars. Select the tool and drag within your document to scroll it around.
Instead of selecting the tool from the palette, you can access it by holding down the
spacebar (unless if you’ve changed this hot key by using the Hot Key Settings menu item
from the Edit menu).

Text  Creates a selection that contains text. First, either click in the document or drag
within it to define a rectangle for the text to be in. A dialog will come up that lets you
specify the text and how to format it (font, style, size, smoothing). With the smoothing
on, the edges of the text will be softened so they don’t look jagged (this will only work if
you have enough memory available). If the text smoothing looks ugly, try doing it again
but with your document set to use thousands or millions of colours (use “Document
Setup…” from the File menu).

Paint Bucket  Flood fills all contiguous pixels (all pixels the same colour) under the
clicked point with the current fill colour.

Paint Brush  Used to paint in the current fill colour with the mouse. If you hold down the
shift key before you paint, you’ll force the your painting to be either perfectly horizontal
or perfectly vertical, depending on which way you start moving. You can change the
brush size by selecting “Brush Settings…” from the “Edit” menu to bring up the Brush
Settings dialog. You can also double click the tool in the tool palette to bring up the same
dialog.

The brush responds to the pressure-sensitive control of a graphics tablet. To learn more,
read the section “Using a Graphics Tablet.”

Eraser  Used to erase parts of your document. You can use the option key to get a smaller
eraser, and you can use the shift key to constrain the eraser. See the paint brush for
details.

Pencil  Use this to draw one pixel thick lines with the current fill colour. If you start
drawing on a colour that is the same as the current colour, you instead erase with a one
pixel thick line. You can use the shift key to constrain the pencil. See the paint brush for
details.

If you hold down the option key when the cursor is in the document window, the cursor
will change to a magnifying glass. Clicking with it will cause your document’s zoom to
be 800%. If you document was already zoomed to 800%, it will zoom to 100%. This can be
very useful when working with fine details.

Rounded Rectangle (Obloid)  This lets you create rectangles with rounded corners. To
specify how much roundness you want, select “Obloid Settings…” from the “Edit” menu
and change the setting in the dialog. The number refers to the radius of the arc of the
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corners. You can also double-click the tool in the palette to bring up the settings dialog.
You can use the shift key while using the tool to constrain your obloid so it’s height and
width are the same, like a square. Uses the current stroke and fill colours.

Line  Lets you create straight lines. Hold down the shift key while painting to constrain
the line horizontally or vertically. Uses the current stroke colour.

Rectangle  Lets you paint rectangles. You can use the shift key while using the tool to
constrain your rectangle into a square. Uses the current fill and stroke colours.

Ellipse  Use this to paint ovals. You can paint perfect circles if you hold down the shift-
key while painting. Uses the current fill and stroke colours.

Ink Dropper  Select a colour in your document with this tool to make it the current
colour for either the fill or the stroke (whichever is currently selected in the Colour
palette). Select “Dropper Settings…” from the “Edit” menu or double-click the tool to
bring up the dropper settings dialog. Instead of selecting this tool from the tool palette
when you need it, you can use this tool at any time by holding down the D key (unless if
you’ve changed this hot key by using the Hot Key Settings menu item from the Edit
menu).

If you hold down the option key while you click, you’ll set the “other” colour (if the Fill
icon is selected, you’ll set the stroke colour). For more information, read the section on
Colours, Fill & Stroke.

Zoom  Use this to magnify your view of the document. If you hold down the option key,
you can decrease the magnification. You can zoom in up to 800%, and zoom out until
your document is no smaller than 32x32 pixels. Double-clicking the tool in the palette
will change the current magnification to 100%. You can use the zoom tool without
selecting it from the Tools window by holding down the E key, and you can use the
zoom out tool by using the R key (unless you’ve changed these hot keys by using the Hot
Key Settings menu item from the Edit menu).

Menus
This section explains the functions of only some menu commands.

The Apple Menu
About Painting… Shows Painting’s About Box. If you haven’t registered, the shown
dialog lets you register. Try holding down the option key when you select that.

The File Menu
New Creates a new 600x400, 256 colour document. You can change this by using the
Document Setup command and checking the “Use this setup for new documents”
checkbox.

Paste New If there is a picture on the clipboard, it creates a new document with that
picture.

Open… Lets you open a image files. If you have QuickTime installed, you’ll be able to
see the preview of files you open.

Normally, Painting can only open PICT files (the standard Macintosh Picture format). If
you have QuickTime 2.5 or better installed, you can open many other file formats, such
as GIF, JPEG, and TIFF. If you open one of these documents, it will open in a window
with “(Converted)” appended to its name.

Save/Save As… Lets you save your documents as PICT files. The save dialog gives
you the option of saving your files as stationery, and allows you to attach custom icons
too. Save As is useful when you want to save your file somewhere else or if you just want
different custom icon settings (in that case, you’d have to replace the original file).

Export/Export JPEG The Export JPEG command is only available when QuickTime is
installed. If you have QuickTime 3.0 installed, the name of the command becomes
Export, and it lets you saves files in several different formats.
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WARNING You should NOT edit a JPEG file and then save it again as
JPEG. JPEG compression causes your documents to lose detail each time
you save. It’s best to save files normally and export a JPEG version when
you need one.

Document Setup… This brings up the Document Setup dialog. With this, you can
change the colour depth, width, and height of the current document. Specifying more
colours for a document will make its size in memory greater, so don’t do it unless if you
need more colours. 256 colours are fine for icons and the like, while thousands or
millions of colours are good for photo quality images.

If you turn on the “Use this setup for new documents” button and then click OK,
Painting will use the settings you specified for future documents made with the New
menu command.

WARNING  Any changes you make in the Document Setup dialog are
NOT undoable, so you should save your document first before making
any changes. Also, if you increase the number of colours in a document
you use more of Painting’s memory. You might not be able to save
afterwards if there’s not enough memory.

Print One Copy Prints a single copy of the current document without showing you a
standard printing dialog. No OK button to hit.

The Edit Menu
Hide Edges If you have a selection, this command will hide the animated edges of the
selection. It’s just in case if you find the selection edges distracting you.

Brush Settings… You can change the size of the circle that the paint brush tool uses
with the Brush Settings dialog. You can choose a size from 1 to 50. There are more
options available if you have an appropriate graphics tablet installed, see the section
Using a Graphics Tablet for more details.

Obloid Settings… You can set how round you want your rounded rectangles
(obloids) to be. Enter a size for the radius of the arc (of the corners of the obloids) that
you want.

Dropper Settings… The Ink Dropper Settings dialog gives you a few options:

Search for matching colour in palette. If this is selected then Painting will try to find a
match of the colour you select with the dropper in the colour palette. If you don’t want
the selected colour in the colour palette to change, make sure this box is unchecked. It is
checked by default.

Add colours to the palette. When you select a colour with the ink dropper tool, Painting
will put up a New Colour dialog to add the colour to the colour palette. This is useful
when you’re trying to build a colour set based on colours that are in your document.

Only if it’s not already in the palette. If this and “Add colours to the palette” are selected,
Painting will let you create a new colour if the one you picked up with the ink dropper
tool can’t be found.

Painting will not be able to find a matching colour in the palette even if you used a colour
from the palette in the first place. This often happens with 256 colour documents. When
you use a colour from the palette that isn’t one of the 256 colours that a 256 colour
document can use, Painting will use the closest match of the picked colour that it can use
in the document. For example, the Orange in GX Common Colours is made up of 100%
red, 49% green, and 0% blue. The closest match in a 256 colour document is 100% red,
40% green, and 0% blue.

Specifying where the colours go. When Painting has to add a colour to the colour palette
from a colour you picked with the dropper tool, you can specify which colour set the
new colours will be put in. If you choose “Selected Colour Set,” Painting will add colours
to the colour set in the Colours palette that is selected (this would be the same set whose
name appears at the top of the Colours palette, above the scrolling area). Alternatively,
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you can make Painting put the colours you pick into a specific set by choosing the
“Colour Set:” radio button and selecting a colour set from the pop-up menu.

Hot Key Settings… This allows you to associate “hot keys” with tools. When you
press a hot key (a key on the keyboard), a tool that you specify with this dialog will
become active. You can choose to make tool changes temporary (so the tool is only
available while you hold down the key), or permanent.

In the Hot Key Settings dialog, there is a picture of the Tools window. Beside each tool
there is a button, and beside each button is the hot key associated with that tool (or
“<none>” if there the tool has no hot key). If you want to define or remove a hot key for a
tool, click the button beside the tool. A dialog will come up asking you to pick a new hot
key. If you don’t want a hot key for a tool, click “None,” then click “OK.”

To make tool changes permanent so that pushing a hot key makes the tool selected in the
Tools window, make sure that the “Change tool only while the hot key is held down” is
not checked.

By default, the space bar is used for the hand, the D key is used for the dropper, the E key
is used for Zoom In (E stands for enlarge), and the R key is used for Zoom Out (R stands
for reduce).

The Painting Menu
Items in this menu only work on selections.

Fill Uses the current fill colour to fill the current selection with colour.

Stroke Uses the current stroke colour to frame the current selection with colour.

Invert This will invert the colour of every pixel in the selection.

Lighten This will make the colours in the selection lighter. Like the Darken command,
this works better with documents that are using thousands or millions of colours. It
doesn’t work on black & white documents.

Darken This will make the colours in the selection darker.

Blur Blurs the pixels together. This is like making your picture out of focus a bit.

Blur More Same as Blur, but it makes your selection more blurry.

QuickTime Effects… Brings up a dialog that lets you choose a QuickTime Effect to
apply to your selection. This requires QuickTime 3 (you don’t need to purchase
QuickTime Pro, the free version will do fine). QuickTime 3.0 comes with eleven effects
you can use, including Blur, Color Style, ColorSync, Edge Detection, Emboss, Film Noise,
Convolution Kernel (Custom Effect), HSL and RGB Balance, and Sharpen.

Scale… Brings up a dialog that lets you make a selected area larger or smaller. You can
specify the scale in terms of a ratio (using percentages) or exact pixels. Use the “Scale To”
pop up menu to select which method you want to scale with.

Rotate… Allow you to rotate the selection to any angle. It requires QuickTime 3. You
don’t need to purchase QuickTime 3 Pro, the free version is fine. You can choose an angle
by using the slider or by typing in a number.

Rotate Right 90° This will rotate your selection 90° clockwise.

Rotate Left 90° This will rotate your selection 90° counter-clockwise.

Flip Horizontally This will make your selection look backwards, as if seen through a
mirror.

Flip Vertically This is similar to “Flip Horizontally,” except that this time what’s was
at the top of your selection would now be at the bottom.
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Edit Text Selection… If you have a text selection (you can make one using the Text
tool) you can change the contents and style of it with this command. As a shortcut, you
can just double-click the selection.

The Window Menu
The menu is divided into three sections. The first section, at the top of the menu, will let
you show or hide floating palettes. The second section lets you bring to the front the next
or previous documents listed in the menu, and lets you Zoom the frontmost window (as
if you had click the Window’s grow box). The last section of the menu is a list of all the
document windows open in Painting. Selecting one will bring it to the front.

The Help Menu
Painting supports Balloon Help for menu items. If you’re unsure what a command does
or why it’s disabled, using the Show Balloons command will probably help. Also, there
are two additional commands there that let you visit the Painting web site and send
email to the author. These launch your web browser or email application. In order for it
to work properly, you have to have Internet Config set up properly (Internet Config
comes with Mac OS 8 and later, but you can download it from the Internet and install it
on System 7.5 too. On Mac OS 8.5, use the Internet control panel instead).

Colours
Painting uses Colour Sets, which are customised palettes of colour. Painting will load any
colour sets found in a folder named “Colour Sets” in Painting’s application folder when
you launch it. If the folder cannot be found, it will use the default “GX Common Colors”
set and ask you to save it when you quit the program.

You can create a new set by selecting “New Colour Set…” from the Colour Palette’s pop-
up menu. You can add colours to any selected set by selecting “New Colour…” from the
same pop-up menu.

You can also drag & drop colours between sets. If you hold down the option key during
the drag, you’ll create a copy of the colour. You can also drag colours to a document to
flood fill an area with that colour (You may find this very useful. It can also be
addictive.). Also, colours can be dragged to the Finder and dragged back into Painting
later for use.

Painting will ask you if you want to save a colour set when you remove it from the
palette (by using the “Remove Set” command from the pop up menu in the palette) or
when you quit Painting. If you want to skip those dialogs, you can have Painting
automatically save or throw out the changes for the colour sets of your choice. If you
select “Edit Set…” from the Colour palette’s pop up menu, you will see the option to skip
the save dialog for the selected colour set.

Fill and Stroke
There are two small buttons on the colour palette. These are the fill and stroke buttons. If
the fill button is selected, all the colours you pick will be used as the fill colour. If the
stroke button is selected, all the colours you pick will be used for the stroke colour.

The fill is used as the main colour for all the tools. The stroke colour is only used for the
shape tools (line, ellipse, rounded rectangle, rectangle) and it’s the colour that frames the
shape you paint. If your fill colour was blue and your stroke colour was black, and you
painted a circle, you would end up with a blue circle with a black border.

You can also disable the fill or the stroke. Do this by selecting the option in the colour
palette’s pop-up menu or by double-clicking the appropriate icon. If the fill is disabled
and you paint a circle on your document, you will paint only the frame of the circle, so
the interior of the circle will show through. Also, you can turn off the stroke so that the
shapes you draw don't have differently coloured edges.

As a shortcut to selecting the fill or stroke button and then clicking the colour you want
to set, you can just option-click the colour. Normally, if the fill button is selected and you
want to set the stroke colour, you have to select the stroke button and then click the
colour you want. To quickly set the stroke colour, you can just option-click the colour
(since fill is selected, the stroke colour will be set. If stroke was selected instead, the fill
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colour would have been set). Option-clicking a colour is a convenient shortcut to setting
the “other” colour. This works with the dropper too.

GIFs, JPEGs, and other file formats
If you have QuickTime 2.5 or better installed, Painting can open files other than
Macintosh Picture (PICT) files. With QuickTime 2.5, you can open JPEG, GIF, TIFF,
Photoshop, and other formats in Painting.

If you have QuickTime installed, you can save files in the JPEG format using the ‘Export
JPEG…’ command from the File menu. If you have QuickTime 3.0 or better installed, the
menu command is named ‘Export…’ instead. If you select it, a dialog box will come up
that lets you save the file in JPEG, Photoshop, QuickTime, and BMP formats.

IMPORTANT  Note that Painting does not change the colours of the
monitor if the file that is opened uses colours that the monitor isn’t
using. This can cause some pictures to look odd when editing them if
your monitor is set to 256 colours or less. If the file was a QuickTime-
compressed Picture file or a converted file (Painting opened it and added
“(Converted)” to its name), Painting will preserve the colours used in
that document. If the file was not a QuickTime file or a converted one,
Painting will lose the special colours for that document when you save it.
If you view the document on a monitor showing thousands or millions
of colours, you’ll be able to see what the document looks like when you
save it.

Using a Graphics Tablet
It’s not hard to create great artwork using Painting and a graphics tablet. Just enable the
stuff in the Brush Settings dialog (you can select Brush Settings from the Edit menu
( � –B) or double-click the paint brush tool to get the dialog).

The Brush Settings dialog has some options that are only available if you have a graphics
tablet properly connected to your Mac. The extra options include two checkboxes that let
you enable pressure-sensitive brush sizes and pressure-sensitive colours, and a popup
menu that lets you choose how colours are modified according to pressure.

Varying Size
With the Size option checked, the harder you push the stylus the larger the brush stroke
will be. The largest you can make it is set by the same old brush size slider.

Varying Colour
If you want to vary the colour of your brush strokes, make sure Colour is checked. By
default, if you press lightly with the stylus you’ll paint the Fill colour blended with a lot
of white. As you press harder with the stylus you’ll get more of the Fill colour.

You have two more options when it comes to colour blending. By using the popup menu
in the Brush Settings dialog, you can also choose to blend your colours with black or the
Stroke colour. The Stroke colour is normally used to frame shapes and lines with colour,
but this option lets you use it with your paint brush too.

Blending the paint brush with the stroke colour gives you a lot of flexibility. The lighter
you push, the more of the Stroke colour you’ll get. The harder you push, the more of the
Fill colour you'll get. With practice, you’ll be able to paint brilliantly.

Tips on Changing Colours
You’ll find yourself needing to change the Fill and Stroke colours a lot. Normally, setting
one of these colours means making sure the correct icon on the colours palette is selected,
and then picking the colour you want.

However, there's a quick shortcut to setting the “other” colour (if the Fill icon is selected,
the “other” colour is Stroke). Just option-click a colour. You can even do this with the
dropper tool.

To make your life even easier, be sure to read up on hot keys. And don’t forget, it’s often
handy to make your own colour set if you find yourself using the same colours often.
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Tips & Shortcuts
Balloon Help
This is the ultimate tip. Painting supports Balloon Help, so if you see something and
you’re curious about what it does, turn on Balloon Help (from the Help menu—the
Question Mark menu on the right side of the screen in System 7) and point to it. Balloon
Help is also available while you hold down the control key, saving you a trip to the help
menu. Not everything is covered by Balloon Help, but you’re sure to find many tips.

Modifiers
Option: The option key makes some tools behave differently. For example, with the
option key down, the zoom tool will zoom out instead of in. The eraser will have a
smaller size. Also, option-clicking a colour will set the “other” colour (if Fill is selected in
the Colours palette, it will set the Stroke colour). This works with the dropper too.

When you are using the pencil tool, use this and click in your document as a shortcut to
zoom to 800% magnification. If you’re already at 800%, you’ll zoom to 100%. This is
useful for quickly checking what your image looks like when you’re working with your
image in 800% magnification.

Shift: This will constrain things. When you are making a selection, holding this down will
let you make a perfect square. If you are using the pencil or paint brush, holding this
down before you click will let you paint straight lines. If you are dragging a selection, it
lets you drag it perfectly horizontally or perfectly vertically (whichever direction you
move first).

Command: When you drag a new selection while holding down the Command key (not
one that you’ve already dragged, and not one that you’ve made using the Paste
command—these are “floating” selections), you can reposition the selection without
dragging the contents of it. If you’re not sure what that means, make a new document,
scribble in it, select something you scribbled, and then Command-drag it somewhere else
in the same document.

Double Clicking
You can double click a few things in Painting for shortcuts.

• Paint Brush, Rounded Rectangle, and Ink Dropper tools: Double clicking on these
tools in the tool palette will bring up their tool settings dialogs.

• Rectangle Selection Tool: Double click this in the tool palette for a shortcut to “Select
All.”

• Lasso Tool: Double click this in your document to select all contiguous pixels of the
same colour. Try it out if you don’t get it.

• The Zoom Tool: Double click this to make your document zoom back to 100%
magnification.

• The Fill and Stroke icons: Double click one of these icons in the colour palette to
enable or disable them. See the section on “Colours” for more details.

• Text Selections: After you make some text using the text tool, you can double click
the text selection to bring the Text dialog back up. From there you can change the
text. This is the shortcut for going to the Painting menu and selecting “Edit Text
Selection…”

Drag and Drop
Drag a colour from the palette to your document to flood fill a selection.

Drag items from the colour palette to the Finder’s trash to delete them without a warning
dialog. Note that the trashed colour appears as a picture clipping in the Finder’s trash.

You may find it useful to drag colours to the Finder for temporary storage. Those
clippings are also a much better way to store a colour than scribbling down the RGB
values in the Note Pad.
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Miscellaneous Tips
When using the pencil tool, option-clicking in the document window will zoom your
document view to 800%. Doing it again will zoom your document window to 100%.

• When you shrink something using the scale dialog, it anti-aliases the shrunk image.
• If text looks ugly with smoothing, try changing your document to use thousands or

millions of colours and try again (use “Document Setup…” from the File menu to
change the number of colours).

• If you use text smoothing and it is not having any effect, it may be because you don’t
have enough memory. Try closing other documents or quitting other applications to
solve the problem.

• When you decrease the colour depth of a document, Painting dithers the resulting
image.

• If you want to paint a shape (such as a rectangle) without painting the fill colour of
the shape in order to just paint the frame, disable the fill colour using the pop-up
menu on the colours palette. As a shortcut, you can also double click the fill icon on
that palette to enable/disable it.

• When you zoom your document, you can click the grow box on the window to make
the window match the size of your zoomed document.

• Clicking the grow box on the info window changes its appearance and, of course, its
size. The bigger size shows more information about the current colours.

• You can option-click the drop flags in the Colours palette to make all the colour sets
‘collapsed’. This is useful if you have a lot of colour sets.

• For more speed while using the tools, hide the info palette so Painting doesn’t have
to spend time updating the coordinate display. This tip is more useful for non-
PowerMacs.

Hot Keys
Don’t forget that you can assign hot keys to tools on the Tools palette. For example, you can set
up Painting so that when you hold down the S key, the rectangle selection tool becomes active
You can set this up using the Hot Key Settings command from the Edit menu. You can read more
about this in the section on Menus.

You can use the Tab key to hide or show all the floating palettes. If the Tools palette is visible,
Painting will hide all the floating palettes. If the Tools palette is hidden, Painting will show all the
floating palettes. That’s not exactly how it works though; there’s a little more logic involved to
prevent it from being annoying. Painting tries to remember what floating windows you had
visible when you used the Tab key to hide them. When you hit the Tab key again, Painting only
tries to make those windows visible.

Memory Usage
The default RAM requirement for Painting, 3 MB, is for PowerMacs that have plenty of
RAM. You can easily use up to half that much if you only work in 256 colour documents.
You can change how much RAM Painting uses by using the Get Info command from the
Finder (in Mac OS 8.5, use the Memory submenu of the Get Info command of the File
menu).

Selections while Selecting
If you have a selection active and you try to make another selection, you’ll still see the
old selection while you make your new one. This is useful for doing things like making a
selection bigger by one pixel.

What’s Obloid?
A quote from a letter by Richard Russel printed in the May 1995 issue of the US edition of
MacWorld magazine:

Almost every piece of software now on the market can draw round-
cornered rectangles. But gee, that’s a mouthful. We can do better. I
suggest obloid for the following reasons: (1) it’s a portmanteau word
suggestive of oblong and ovoid; (2) it has the same number of letters as
square and circle; (3) it isn’t being used for anything else; and (4) as far as
I can tell, nobody owns it.
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I used the term “obloid” because “Rounded Rectangle Settings…” was too big to put in
the Edit menu. And because I like it.

Thanks
Thanks to Alex Curylo, James Jennings, Alastair Rankine, John Thomas, James W.
Walker, and Itrat Khan. Thanks to Tim Wall for help with using the graphics tablet
drivers. Also, many thanks to Jam & Spoon for making fabulous music. If anyone knows
how I can get the Find Me CD single PLEASE contact me.

You’ve spelt colors wrong.
Well, that’s the Canadian spelling and I’m Canadian. Sorry.

But you’ve spelt other things right.
Like most Canadians, I’m sloppy with my English.

Yet more stuff
This document was published using eDOC Creator, by Michel and François Touchot.

Sarwat’s name isn’t pronounced Sar-what. It’s pronounced more like Sirwath. Some
people like to use a ‘v’ instead of a ‘w.’ It’s really not spelt very well.

Known Problems
Problems with Kaleidoscope and Aaron
If you select some of the greys in the colour palette and you paint rectangles with them at
a certain size, you may find yourself painting progress bars. This has to do with the way
Aaron patches the System to draw progress bars. To get around this you can draw your
rectangle with a different height. You can also draw it in a different colour and flood fill
it. And of course, you can turn off Aaron/Kaleidoscope. You’ll also notice weird stuff if
you use the R: 80%, G: 80%, B: 100% colour in Apple Icon colours. In that case, you get
the background of the progress bar.

Reporting Bugs
Please, PLEASE report any bugs or interface quirks you encounter (be picky). Just send
email to sarwat@kagi.com about it.

Redistributing Painting
Only give people the original Stuffit archive that you hopefully have that contains the
Painting application, the Colour Sets folder (along with the 3 colour sets), the Painting
Readme file, this Painting Documentation file, and the Register application. Do not
redistribute modified versions of Painting. Painting may not be redistributed
commercially in any way (except for online services) without my written consent.

Legal Stuff
LEGAL DISCLAIMER. Use Painting at your own risk. Painting comes with absolutely no
warranty. Sarwat Khan is not liable for any damages whatsoever caused by Painting. If
you live in a country, state or province that makes this disclaimer void in any way, you
may not use Painting.

Contacting the Author
Send mail and comments to sarwat@kagi.com.
Check out Painting’s web site at http://sarwat.net/painting/
Check out Sarwat’s web site at http://sarwat.net


